AIDE POUR OPENOFFICE.ORG

INTRODUCTION

Le traitement de textes est un logiciel qui sert a écrire et mettre en forme un texte.

De nombreux logiciels sont a disposition, du plus simple au plus sophistiqué, du gratuit au tres cher, du
format propriétaire au format ouvert.

Le choix du logiciel dépendra de |'utilisation que |'on fera du document fabriqué.

LEs FORMATS

Tout utilisateur de logiciel, lorsqu'il enregistre son travail produit un fichier. Ce fichier est enregistré
dans un format, qui est souvent celui du logiciel, fait par le logiciel et fait pour le logiciel.
Et la, deux cas de figure se présentent :
- le format est fermé : on ne sait rien dessus, de son fonctionnement, uniquement détenu par
I'éditeur du logiciel ; les coulisses sont inconnues ; la dépendance est totale.
+ le format est ouvert : on conndit son fonctionnement, ses coulisses techniques, qui sont
publiées, connues, réutilisables librement ; il y a indépendance.
Les formats fermés sont par exemple ceux de Word (traitement de texte de Microsoft) ou de
QuattroPro (tableur de Corel). Le formats ouverts sont par exemple le HTML, le format des pages
Web qui est connu, publié par le W3C (World Wide Web Consortium, http://www.w3c.org) ou le PDF,
établi par Adobe, connu et librement utilisable, pour diffuser une version figée de son document.
Il existe des formats ouverts et structurés, ce qui est meilleur encore, tels que XML et ses
dérivés, de plus en plus utilisés par |'ensemble de |'industrie informatique.
Dans le cas des formats fermés, les informations saisies ne sont pas mditrisée par les auteurs, car
dépendent des décisions de |'éditeur du format. On a ainsi 5 dangers, souvent rencontrés par les
utilisateurs :
- Impossible de communiquer et d'échanger I'information :

- si le logiciel n'est pas présent sur les machines destinatrices : quand le logiciel n'existe
pas pour sa machine ou est trop cher pour tre acquis, pas d'acces a |'information !

- si le logiciel des destinataires n'est pas la méme derniére version utilisée par |'auteur du
document, le fichier, au dernier format fermé en date n'est pas utilisable par le logiciel
dans ses versions précédentes.

- Aucune pérennité de |'information :

- si I'éditeur renonce & prendre en compte un format jugé trop ancien dans son
logiciel actuel, les informations produites (par les particuliers, les entreprises, les
administrations, les associations) ne seront plus exploitables ;

- si |I'éditeur arréte le développement et la vente de son logiciel (pour recentrage de
sa gamme de produits, pour rentabilité trop faible), les fichiers n'ont plus I'outil pour les
lire, I'information est perdue ;

- si |'éditeur disparait (faillite, rachat, fusion), les informations sur les fichiers au
format fermé de ses logiciels disparaissent aussi... et donc la possibilité de les réutiliser.

Il existe des formats ouverts' équivalents évitant les dangers des formats fermés. L'interopérabilité,
c'est-a-dire |'utilisation possible sans logiciel exclusif, doit tre assurée. Ainsi que la pérennité des
informations.

Paragraphe extrait d'une conférence de Thierry Stoehr? aux RMLL2004 & Bordeaux

! http://thomas.enix.org/pub/Il-utbm/formats_ouverts/formats_ouverts.html

2 http://www.autourdulibre.org/article66.html
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CHOIX DU LOGICIEL

Une fois que |'on a opté pour un format ouvert, il faut sélectionner le logiciel qui convient au document
a fabriquer.

+ Si I'on fait une note sans mise en page sophistiquée, il est inutile d'utiliser une suite

bureautique, un logiciel lIéger (notepad) suffira.

Sil'on a des tableaux sans calculs dedans, le tableur sera inutile, le traitement de textes peut
faire I'affaire.

Le « poids » du fichier généré peut aussi €tre important, notamment si le fichier est envoyé
sur internet. Les fichiers OOo sont nativement compressés.

- Le prix d'achat du logiciel est aussi un élément important dans le choix du logiciel, OOo est

gratuit.

- Si le destinataire du fichier n'est pas en possession du logiciel, il est possible d'enregistrer le

fichier dans un format « presque » universel lisible par tous les navigateurs : le pdf.

Pour toutes ces raisons, et d'autres®, nous choisirons OpenOffice.org, comme support de ce cours.

OreNOFFIcE.orRe (O00)

Le nom OpenOffice étant déposé, OpenOffice.org est le nom officiel de la suite bureautique libre,
comprenant tout ce que I'on attend : un traitement de texte, un tableur, une présentation assistée, un
module de dessin vectoriel. Il n'y a pas de module de PAO, ..., mais est-ce bien utile ?

Ce stage se basera sur des travaux divers (pourquoi réinventer la roue ?2??)

- site officiel du projet francophone OpenOffice.org*

site OpenOffice.org’, choisir le « Parcours guidé pour |'utilisation de Writer »

- site OpenOffice.org®, choisir les « Writer - exercice - 01 & Ox»
- académie de Versailles’
- cours interactif en ligne®

Avant de commencer tout document, il faut lire les régles de bases de la typographie’ ...

VO ® N o O » w

d'ordre éthique, ordre professionnel, ordre moral, ... (que d'ordre )

http://fr.openoffice.org/
http://fr.openoffice.org/Documentation/Guides/Indexguide.html

http://fr.openoffice.org/Documentation/Exercices/index exo.htm

http://logiciels-libres-cndp.ac-versailles.fr/article.php3?id article=40

http://info.sio2.be/tdtooo/

http://www.interpc.fr/mapage/billaud/typopao.htm
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LES FONCTIONS DE BASE DU TRAITEMENT DE TEXTE

Le traitement de texte de OOo est le module « writer » de la suite bureautique.
Au démarrage de windows, OOo se charge en mémoire et se met en attente dans la barre des tdches en
bas a droite.

u Clazseur
IE] Présertation

[i# Dessin

”'i A partir d'un modéle

Pour lancer un module OOo, clique-droit sur ff puis sélectionner le
module qui convient :, soit ici Texte.

7= Ouwtir un document

. v Chaiger OpenOifice.org au démarrage du systéme

Guitter le démarage rapide

L'interface graphique du logiciel est « presque » entierement paramétrable, il faut la configurer pour
qu'elle soit la plus facile d'emploi compte tenu du travail que vous allez lui demander.

En général une action est obtenue de plusieurs maniéres différentes : avec la souris dans les menus
déroulant de la barre de menus, dans la barre de fonctions en cliquant sur un icdne (s'il existe), avec un
raccourci clavier (s'il existe).

Exemple : pour coller

menu Edition>Caoller

EE= [ e T
T . Pt Al . .
sur I'icne : & e combinaison des touches :
7 Y
-
de la barre de fonctions © | EE— el + V
E

Selon nos habitudes, on essaiera de varier la fagon d'opérer, pour gagner en rapidité. Les icones qui ne
servent pas ou peu seront a désactiver.

Se positionner dans une barre d'icones et cliquer le bouton droit de la souris qui fait apparditre un
menu contextuel puis Boutons visibles, la liste des ic6nes disponibles apparadtt, il n'y a plus qu'a valider ou
non.

Il est possible aussi de faire apparditre/disparditre une barre d'outils de rajouter ou supprimer des
icones disponibles Personnaliser..., de modifier les menus déroulant Adaptation...>Menu, d'affecter des
raccourcis clavier a certaines actions Adaptation...>Clavier.

Il faut aller faire un tour dans le menu : Outils>Options... et visiter tous les parametres par défauts.
Touche F4, regles, dictionnaires, chemins, caracteres non imprimables, vérification automatique
d'orthographe, optimiser |'affichage, annuler/reprendre les derniéres modifications, ...
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Manipulations des fichiers : menu Eichier

« Nouveau : création d'un nouveau document, quel que soit son type

« Ouvrir... : ouvre un document déja existant

- Enregistrer : enregistre le document courant a I'emplacement ou il a été ouvert

- Enregistrer sous... : enregistre le document courant a I'emplacement que vous spécifiez

« lorsque le document doit étre enregistré, il faut préciser dans la boite de dialogue qui
s'ouvre : le lieu de stockage du fichier, son nom et son type (c'est son format).
Le format d'enregistrement est important si |I'on veut échanger le fichier avec d'autres
applications. Par défaut le fichier peut-tre enregistré automatiquement dans un format.

Tout se passe dans le menu Format ou menu contextuel avec un clique droit de la souris.
+ Mise en forme de la page Format>Page.... format, dimension, orientation, marges, colonnes,
en téte, pied de page, notes de bas de page, ...
+ Mise en forme de paragraphes Format>Paragraphe... : retrait, écarts, interligne, alignement, ...
Un paragraphe est tout ce qu'il y a entre deux marques de paragraphes (retour a la ligne).
- Mise en forme des caracteres Format>Caractéres... : police, style, taille, effets, position, ...

Ily a deux fagons d'opérer :
- le texte est saisi au km, puis ensuite on se préoccupe de sa mise en forme
- on utilise un modéle qui posséde déja sa mise en forme.

Pour une bonne gestion de |'espace et par souci de simplicité, nous emploierons les tableaux sans
bordure pour insérer des images dans les cellules.
Dans le menu Insertion>Image>A partir d'un fichier... et sélectionner |'image.
Remargue : il faut « travailler » I'image dans un logiciel approprié et éviter de redimensionner
dans le traitement de texte.
Une fois |'image insérée il faut adapter ses propriétés : menu contextuel Image...
- Disposition : tout a I'avant, vers |'avant, vers |'arriére, tout a |I'arriere.
+ Alignement : horizontal et vertical.
- Ancrée : a la page, au paragraphe, au caractére, comme caractere.
- Adaptation du texte autour de |'image :

xemple :

L'expression «Logiciel libre» fait référence a la liberté , o Y s .
. s . L'expression «Logiciel libre» fajf référence a la liberté
pour les utilisateurs d'exécuter, de copier, de R

. Cer g g our les utilisateurs er, de copier, de
distribuer, d'étudier, "% de  modifier et p' ) u. v . t ! . p !
v M L distribuer, d'ét , ) rea\-_gj}.\d améliorer le
d’améliorer le n, J0giciel. Plus logiciel. Plus précisémenr e fdif Féférence a quatre
précisément, 1—"'/_/, — TR elle fait| 09'c'el FlUS P , — . . q

irx = N - types de liberté pour ['utilisateur du logiciel :
référence a : quatre types

de liberté pour |'utilisateur du logiciel :

Type : ancrage Au paragraphe, position H centre, V du Type : ancrage Au paragraphe, position H centré, V
haut, adaptation paralléle, Contour, Seul I'extérieur. centré, adaptation Continu, A I'arriére plan.

Sélectionner |'image, clique droit Image... onglets Type et Adaptation du texte, et visiter les autres aussi.
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Pour une mise en page rapide et peut-&tre plus fine, on peut aussi aligner du texte avec des tabulations,
sans utiliser les tableaux.

Les marques de tabulations affectent un paragraphe. Mettre le curseur dans le paragraphe et soit
clique droit Paragraphe... , soit menu Format>Paragraphe... et onglet Tabulation.

Exemple : Emploi du temps

chapitres FITP@S oot page temps nécessaire
1 Introduction .........cceveeeeeeeeececeeeeee, 9 35 min
2 Les formats .......ccooeveeeeceeeeee e 11 2h 20 min
3 Choix du logiciel ..........ccoeerevrerrreinrrirnes 132 1h
14 Le traitement de texte .........ccccocovvinenncnn. 1254 32h 47 min

On remarque que les chapitres sont alignés et centrés, les titres sont alignés a gauche avec des points
de suite qui s'arrétent tous au méme niveau, la numérotation des pages s'alighe sur les unités (d droite)
et les heures sont alignées.

Caractéres de

Position Type ; observations
remplissage
chapitre 1cm centré aucun
: rajouter un espace
titre 3cm gauche aucun Jour P
apres le texte
fin des points 10 cm adroite L.
page 115 cm a droite aucun

insérer un espace
temps 14 cm décimal, espace aucun devant les minutes
et apres |'heure

Les marques de tabulations sont inscrites dans la regle, en haut de la page, on peut aussi directement
les positionner.

Utilisées pour apporter des informations supplémentaires sans surcharger le texte.

Insertion d'une note de bas de page %]

Menu Insertion>Note de bas de page... Humérotation - |
/ . . . ' Bukomatique!
La numérotation des notes peut se faire automatiquement ou o - pnder__|
manuellement. = ae |
Les notes peuvent se trouver en bas de chaque page ou en fin de i e —
* Mote de bas de page

dOCUﬂ'\CnT. £ Mot de fin

OpenOffice.org propose un correcteur orthographique qui utilise celui du projet libre Gutenberg. Il
n'offre pas pour le moment de correcteur grammatical.

Par le menu Outils>Vérification orthographique> Vérification ou F7 vous lancez la vérification du document ou
bien Vérification automatique celle-ci est permanente et souligne en rouge le mot si une faute est détectée.
Un dictionnaire des synonymes est aussi disponible Outils>Dictionnaire des synonymes... ou CTRL+F7.
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Lorsqu'un document est long et que I'on veut une certaine homogénéité, les mémes actions de mise en
forme se renouvellent. C'est pour éviter ce travail répétitif que |'on applique un style qui rassemble les
divers formatages d'un ensemble donné (texte, paragraphe, tableaux, page, ...).

De plus si I'on veut modifier |'apparence d'un long document, il suffit d'agir sur le style et tout le
document est modifié.

. A, . Shyles de paragraphe
Pour faire apparditre le styliste :
PP - STY EaooE »Es
menu Format>Styliste ou F11. T E——— ~
interligne "l
. \ \ . de bas d
Le styliste gére les paramétres de mise en forme des M, T
\ Retrait texte
paragraphes, des caractéres, des cadres, des pages et la peoar]
, . retraibl avec puce
numerotation. (bandeau du hGUT) retraétzdavec puce
Sk,
. , T;clzeanrormal
On peut afficher : tous les styles par défaut, les seuls styles Ine, il
utilisés, les styles personnalisés, les styles de texte, de (T2 =
chapitre, de titre, d'index ... (fenétre du bas) [styles utiisés =]

Positionner le curseur dans le paragraphe et sélectionner dans le styliste le style de paragraphe
prédéfini qui convient. Si le formatage ne convient pas, il est possible d'en modifier certains
éléments.

Dans le styliste, clique droit sur un style et Modifier....

La feuille de style ainsi créée et modifiée est attachée au document qui I'a générée.

Menu Fichier>Nouveau>Texte, une feuille vierge munie des styles prédéfinis s'affiche.
Dans cette feuille on construit le document avec les styles nécessaires et on |'enregistre :
- Menu Fichier>Modéle de document...>Enregistrer... donner un hom au modeéle et sélectionner la
catégorie (par défaut).
Ce modele est enregistré dans le répertoire par défaut des modéles voir configuration
de I'interface.
Inconvénient, le modele est sur le disque local et non accessible sur le réseau.
- Enregistrer le document, comme un modele a I'endroit désiré.
Menu Fichier>Enregistrer sous... sélectionner |'endroit d'enregistrement, donner un nom
au document et surtout sélectionner le type de document modeéle avec I'extension stw.
Ce document pourra par la suite tre transféré ou cela sera nécessaire.

On va récupérer la feuille de style d'un document et I'affecter a un nouveau document.
Dans le nouveau document Format>Styles>Charger...
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- si le fichier est un modele, il apparait
dans la fenétre de droite et sa
catégorie dans la fenétre de gauche,

- sinon aller chercher le fichier de style
avec le parcoureur :

A partir d'un fichier...

Charger les styles B2

AIDE PoUR OPENOFFICE.ORG

bl
Annuler |

entets_college Aide |

Arrigre-plans de présentation
Présentations

¥ Teute ¥ Cadre v Pages [ Mumérotation v Ecraser & partir dun [Ithler’.‘.l

OpenOffice.org est muni d'un explorateur de document, cet outil est bien commode lorsque le

document est structuré et long.

Menu Edition>Navigateur ou F5.

B = Titres
Permet d'organiser la structure d'un long document, .
’ ] . 4 . ' H Choix du logiciel
de gérer |'ordre des différents chapitres, d'avoir une S 0

vue d'ensemble du document.

po| ot
) | Eﬂi@lll

fes Fonctions de base du traitement. de texte:

manuel_OpenOffice sxw (Ackif) LI

Dans un document long, soit on laisse le logiciel gérer les sauts de pages, soit on le gére soit méme

permettant ainsi de maitriser la mise en page.

xemple : insérer une page format paysage dans un document format portrait.

- créer un style paysage

- créer un document standard

- insérer un saut de page, manuel

- et choisir le style paysage

- ensuite revenir au style standard

Insérer un saut
Type
P ‘ P I
" Retour 413 ligne
@ annuler |
(ol
Aide: |
tyle
[Aucun] o
= e e de page

La numérotation des pages d'un long document est automatique.
On insére un « champ » numéro de page : Insertion>Champ/ et choisir le bon champ. D'autres champs sont

disponibles : date, heure, sujet, titre, auteur, ...

xemple : page Numéro de page sur Nombre de pages donne : page 7 sur 9
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LA PRESENTATION AssISTEE PAR ORDINATEUR

C'est une fonctionnalité du traitement de texte qui permet une mise en page structurée comme
pour un journal.

Si le document doit tre transformé au format html pour &tre publié sur internet, les cadres
seront gérés de maniére plus ou moins fantaisiste. Il faudra dans ce cas préférer une mise en page
avec des tableaux.

Mettre |'affichage en mode page : menu Affichage>Zoom...>Page entiére. La page est toute entiere a
I'écran, c'est petit, mais suffisant pour effectuer la mise en page avec les différents cadres.
On réfléchit avant a la mise en page et on positionne ensuite tous les cadres : menu Insertion>Cadre...>
La boite de dialogue des cadres appardit, il y a deux solutions :
- on valide et on ajustera les dimensions a la souris
- on définit toutes les propriétés du cadre dans cette boite.

Cadie
Ongle'l’ Type Type | Options | Adsptabior i teste. | Hyperlen | Bordure | Aniseesplan | Colonnes | Macro |
. . . . Talle Ancrage
- Taille : préciser les dimensions du cadre a——
z . . [ Relatif B fuparagraphe
O Proportionnel : conserve les proportions du cadre i ] | s _
. e’ . /7 /7 € Comme caractére
initialement inséré . a7 R ‘
N Eropartionnel
O Hauteur automatique : ajuste la hauteur du cadre a la P s ascnsios —
longueur du texte (inconvénient : modifie la mise en L e | T
[ En wis-&-vis sur les pages paires
page '”). . ertical Jouhaut =& s 2 gour [mere = |
- Position : position du cadre dans la page
- Ancrage : choisir a la page pour une position absolue ] | st |
Cadre
Type Options | Adaptation duteste | Hyperlien | Bordure | [Amiste-plan | Celonnes | Macra |
Hom [ttre_page]
Ongle-‘- : Op-hons Eroreen :<numn> j]
, . Lien suivant <hucn &
- Nom : afin de se repérer plus facilement dans le document, otk
. . v, . ’ ™ Contenu
il sera utile de repérer les différents cadres du document. > pagin
. age . . . ¥ Taile
- Protéger : O Position et O Taille, indispensable lorsque la s
. . [~ & éditer dans le document en mode Lecture seule
mise en page est faite. B e
Orientation du texte [tiiser les paramétres de lobjet supérieur =l
o | senuer aide | ménalsation |

Une fois les cadres positionnés dans la page, il faut les remplir, soit de texte, soit d'image, soit de
dessin, ...

- Si le texte est plus court que |'espace disponible :
- on diminue le cadre, mais la mise en page est remise en question
- on insere une image ou on laisse tel que
- Si le texte est plus grand que |'espace disponible, un petit carré rouge apparait dans le coin
en bas a droite du cadre :
- on agrandit le cadre, mais la mise en page est remise en question
- on chdine ce cadre avec un autre (plus loin dans le document) et le texte continuera dans
ce nouveau cadre.
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Il faut absolument que |'image soit travaillée dans un logiciel approprié (Gimp par exemple) et
que ses dimensions correspondent a celles du cadre.

Lorsqu'une image est sélectionnée, une barre d'outils spéciale s'affiche, elle permet d'ajuster
quelques propriétés de cette image.

LEs FONCTIONS DE DESSIN DU TRAITEMENT DE TEXTE

La barre d'outils de dessin se détache et
se positionne n'importe ou.

Les dessins réalisés avec cette barre
seront simples. Dans le cas de réalisation
complexe, il faut utiliser le module de
dessin vectoriel draw de OpenOffice.org.
Faire attention a I'ancrage de ces
objets ...

Dans I'ordre :

- sélection du dessin

- insertion d'une ligne avec adaptation des
extrémités et du style de ligne

- insertion d'un rectangle plein (si I'on veut un carré
on maintien la tfouche ' Maj enfoncée)

- insertion d'une ellipse ou d'un cercle plein (ou
vide ...)

- ligne polygonale (succession de segments) Fonttans s i

+ courbe, maintenir le bouton de la souris enfoncé et & |\ |m|@| |4 <|c|e|e| T|X|E
tracer la courbe. On obtient une courbe de Bézier
(décrite par ses tangentes)

- ligne a main levée

- arc d'ellipse ou de cercle

- secteur d'ellipse ou de cercle, premier clique pour
le début du secteur et second clique pour le fin du
secteur.
Sélectionner le dessin et avec la main re-
dimensionner |'ouverture du secteur.

- Segment d'ellipse ou de cercle

- cadre de texte s'adaptant a la longueur du texte

- texte animé ;
. ) C'est une
- bulle, le dessin est basique. bulle

Si l'on fabrique un dessin constitué de plusieurs
¢léments, il faut les grouper pour ne former qu'un
seul élément.

On sélectionne un premier élément et tout en

maintenant la touche Maj enfoncée, on E
sélectionne successivement tous les éléments =
constituant I'objet ensuite clique droit et Groupe.

Par suite on pourra toujours rentrer dans le

groupement pour modifier, ajouter ou supprimer un
élément.

Chaque béchet est constitué d'un triangle,
d'un rectangle et pour le pied de plusieurs
segments.
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